Texture compression for 2D game

Unity seems to use more highly compressed textures as the camera zooms away from the objects. I am trying to use simple textures on planes to make 2D style graphics, but this texture compression is problematic. Is there any way to disable it or extend the distance it compresses at?

  1. Select the texture in the Project view
  2. In the Inspector turn off "Generate Mip Maps" to disable the filtering as the texture gets further from the camera. Unity, as with most 3D applications, filters textures as they get further away. This is to help prevent Moire patterns.
  3. You can also change the "Filter Mode" to "Point" if you want to disable filtering entirely

You're probably seeing the results of mipmapping, not compression. You can tweak the settings a bit by going to the texture import settings window.

One option is to turn off mipmaps entirely. I wouldn't recommend that as you'll get sparklies when the texture is far away, and it's also slower for the graphics card to render. You could try changing the mip map filtering options to see if you get better results, or try turning on aniso filtering or trilinear filtering.