Texture not showing detail on inported mesh.

I have imported a 3ds file which I exported from VectorWorks 9. The drawing had no textures assigned in VW, but I imported it into Unity and then assigned material to the bits that make up the mesh. But on the imported mesh the texture is displaying no detail (eg no texture). It’s displaying the colours of the various textures assigned to the various materials I have tried out, but, though they are displaying perfectly on objects (cubes and the like) I create in Unity, these materials are displaying color but not texture on the meshes I have imported. I might add that (though it looks like the texture was either so stretched out that it lost all detail, or so compacted that the same thing happened, it is not an issue either with the scale of the objects, nor with the scale of the materials. I have tried every combination of scales and offsets on mesh and material to no avail. Please help!


The only way to display a texture into a 3d object is to UV MAP the texture into the object. This process is usually performed 3d editor side, with the appropriate tools (usually mesh=> edit=> uv unwrap=> open image=> position uv map above the image).

Sadly there’s no ‘easy’ way to map a texture into a 3d object, but the easiest is possibly doing it in the 3d editor (you can do the same through code, but that’s actually pretty demanding for even slightly complex 3d objects).