Textures look terrible in game mode

I started doing the space shooter tutorial and did everything that was done in the video, however when I entered game view, the ship looked as if it was in an 8 bit game. I played with the graphics and set everything to the highest degree possible, as well as the quality settings, I set graphics emulation to no emulation, and now that I tried everything I could think of with no success, I am out of Ideas.

Look at your Gameview Tab. The Scale is all the way up to 5. This causes the blurry look.
In addition, did you set your sprite’s FilterMode to point ?