The AnimationClip used by the Animation component must be marked as Legacy.

I try to go to the animation file and set it to legacy mode but the animation type doesnt display, i tried too in debug mode but isnt here, im using Unity 5.5, i heared in other tread what opening the anim file i can set it via script but i go to the files and i only see fbx and meta files not anim files.

Please help, i cannot play animations :frowning:

Well i founded the option in the inspector, choosing the file from the assets and clicking in the rig tab, here is the legacy mode in animation type.

The problem now its what the animation doesnt animate, but no errors now, legacy mode fixed it.