"The associated script can not be loaded" & "The script needs to derive from monobehaviour"

I am currently trying to merge 3 “2019.2.17f” project to a single “2018.4.16f” project.
I made a package for each of my projects and imported them to my single project, and none of the script seems to be working. It all says “The associated script can not be loaded”.

I tried:

reopen project

restart computer

reimport all asset

check class name

remove script component and add it again (“The script needs to derive from monobehaviour” Error)

But nothing worked.

Please help!

Any help is appreciated!

Well you most likely have compiler errors which you happily ignored ^^. If there is ANY compiler error in any of the scripts in your project, none of it will be working. All scripts are compiled into an assembly. If even one contains errors the compilation process fails and you don’t get a new / updated assembly.

Always solve problems from the top to bottom. So the first error is the only one you should care about. Any further error might just be the result of the first one.

Maybe you try to use an old script that used certain features / methods / APIs which do no longer exist. Maybe you forgot that Unity has now organised many of the built-in features into packages which you have to include through the package manager. We can’t tell you want the problem might be since we don’t see your console. So check your console and look at the first error at the top.

Note if you want to update your question to include the actual error you have, please edit your question and include the error as text and format it as code (select the text and press the 101 / 010 button). You can copy text from the bottom half of the console window.