The "+" icon in Parameters within the Animator is greyed out, what am I doing wrong?

So I am obviously new to Unity and game development as a whole, but I am following this amazing guide to get me started. However, he is using an older version of Unity Personal Edition and it seems to be working differently (obviously) at some points. So, he is asking me to create a float for making my 2D character actually show that he is moving in a specific direction by connecting the animation to it. However, the “+” icon is greyed out and I cannot create a new parameter. What do I do?

Nevermind, figured it out! Make sure the game isn’t in PLAY mode. Click the “Play” button on the “Game” screen and make sure it is off, stupid mistake by myself!

Is the Animator created? maybe you don’t have animators in your project, I think it’s greyed out in the animator window when you don’t have any animators. Not very sure…