"The module which implements this component type has been force excluded in player settings."

This is for a group managed project, all 3 of us are unable to edit components and deleting the project library does not help.

Replace manifest.json with a fresh project’s manifest.json or from another project

In case anyone else finds this post in future, it also requires the terrain physics package to be included in the package manager (or:
“com.unity.modules.terrainphysics”: “1.0.0”,

Not a very helpful error is it? There’s nothing in player settings.

In my case I got that in the inspector, just under a collider. It happened because I had removed this dependency from my packages manifest.json

“com.unity.modules.physics”: “1.0.0”