The program can't start because UnityPlayer.dll is missing from your computer.

our Game Design classes are receiving this error when trying to compile on an instructor’s station. “The program can’t start because UnityPlayer.dll is missing from your computer.” All systems are running Windows 10 64bit Enterprise addition. Do I need to reinstall unity on our instructor’s station? Did I miss a check mark during the installation?

All of our classroom computers were upgraded from Unity 4.6.3 to 2017.2 last friday.


Like @dmmsskn says, it’s a feature in the new version of Unity. When you copy the exe to another folder, you’ll need to copy the UnityPlayer.dll too.


Section “Impovements”

Windows: The player executable has been split into two parts: a signed UnityPlayer.dll that has all the engine code, and a wrapper executable that merely calls into this DLL at startup. The source code for the executable can be found under Editor\Data\WindowsStandaloneSupport\Source\WindowsPlayer. It can be rebuilt with VS2015 as long as you have “Common Tools for Visual C++ 2015” and “Windows XP Support for C++” installed.

Personally either reinstall or rollback to last working version.

UnityPlayer.dll is missing. I built a stand alone unity game EXE. It played fine for almost a week. With no changes being made by me I get this error out of the blue. Now the game that has been working all along does not even start. I search my entire computer and there is no UnityPlayer.dll and I am pretty sure there never was one. I have version 2017.3.0f3.

This can also occur if the directory is in certain folders, for example I sent a build to a friend, which has worked previously, but he unzip’ed it into the ‘Transfers’-folder on Windows 10 (uncertain of the folder-naming, since his language isn’t english), but the error popped up, saying the UnityPlayer.dll was missing (despite actually being in the folder).

When he moved the folder to the desktop and tried to run the build again, it worked perfectly.
I’m assuming this is some restriction/safety-measure by Windows 10, since similar has occurred in earlier versions. Just a heads up for anyone else stumbling by

I just moved the game folder to desktop like @Westland suggested and magically UnityPlayer.dll appeared where it never was when in transfer folder. Thanks ,The problem for me was solved when I changed the folder. I just did what @Westland said. And then UnityPlayer.dll magically apperared in the folder. Thanks