"The type or namespace name 'UnityWebRequest' could not be found." Version 5.5.2p2

Try to get some networking functionality up and running using this as a guide:

…but am getting the above error. Including “using Unity.Networking;” at the top results in the same error:

“The type or namespace name ‘Networking’ could not be found”

“UnityEngine.Networking.dll” is present in


You need to include the UnityEngine.Networking namespace (not Unity.Networking)

using UnityEngine.Networking;

the correct method is Send();

as found in here, however, these method are obsolote, so if you are using unity 2017.2 and below, use Send(), if you are using 2017.3 and on, use SendWebRequest().

I’ve the same problem (with “using UnityEngine.Networking;”, obviously):

error CS1061: Type UnityEngine.Networking.UnityWebRequest' does not contain a definition for SendWebRequest’ and no extension method SendWebRequest' of type UnityEngine.Networking.UnityWebRequest’ could be found. Are you missing an assembly reference?

The Unity official example code at


is not working.
I reported problem hoping someone at Unity Labs take a look at it.

Did you solved?

Thank you.


Same problem here. The official example code is wrong, at least in 2017.1.2f1.


You can use SendWebRequest() in return yield and extraction information use downloadHandler.text, this functions solve mi problem.