Thousands of duplicate symbols for architecture arm64 when building from Xcode

Hi,

I am building an AR app from Unity for IOS devices. When I attempt to build my Xcode project to an IOS device, the build fails and I receive an error saying there are duplicate symbols for architecture arm64. Sometimes I don’t have this error when building and sometimes I do… Sometimes there are 80k duplicate symbols, but this time round it says there are over 100k duplicate symbols.

The error messages point at the DerivedData folder, but I have cleared that out and attempted so many solutions online. There are no ads in my project, and as I said it works sometimes when Xcode decides it can be bothered. Building through Xcode has proven to be the absolute worst experience and I can’t put my finger on the problem, but this is causing a serious issue with my work.

Any help or suggestions would be appreciated.

Man, I spent the past two days trying to find the answer to this same issue.

Seemingly randomly, Xcode would eventually work… I think I might have figured out what was triggering this to happen.

When I looked in the Classes/Native folder in the latest iOS build folder (where all of the duplicate files were) I noticed that the files were last modified hours prior. When I tried to build the project in Xcode, it made duplicates that had been modified even more hours prior… It all seemed strange to have reused files and then duplicates that were even older…

So, I went into a random C# script and removed a comment so I’d have a reason to save and let Unity reload them.

I then built again and sure enough, the files in the Classes/Native folder were all freshly created.

When I built in Xcode it finally all worked again, without duplicates.

The settings below were also the only things I touched in Xcode before doing this new successful build (not sure if they contributed to the success, as I’d fiddled with them a bunch before also):

Project

Architectures

Build Active Architecture only

iOS (selected iOS rather than “iphoneos”)

Deployment

Targeted Device Families: iPad

Apple Clang - Code Generation

No Common Blocks: No

** Target**

Architecture

Build Active Architecture Only

iOS(selected iOS rather than “iphoneos”)

Deployment

Targeted Device Families: iPad

I’m sorry this isn’t more definitive or much of a pin-point, but I hated seeing this post go ignored while I was wrestling with the issue for days also. I hope any of this helps!!!

Hey man I was reading up on solutions for hours and it all didn’t help till I found across post. Appreciate it man

Thanks for posting @AboDabo that worked for me. Was pulling my hair out. Simply adding a random comment to my script and rebuilding fixed everything… Didn’t change any other settings in Xcode. Super weird.