Thread shouldn't be running anymore

I’m getting this mysterious error while editing my project in Unity 4.1.2f1; mysterious because that’s all it says in the Console, my scenes seem to run correctly despite it, and I can’t find any reference to it anywhere on the various Unity forums. I’m just wondering if it might indicate a problem I should fix.

If I stop playback and re-start it, the error usually disappears. I can’t purposely cause the error to appear. Also, when it does show up, the error is thrown on every frame.

Update: the error is thrown every time I playback now. Hmmm.

Update 2: it appears to have something to do with the WWW class. They pop up only while downloading image files for the first time I run the program. If I reload them without stopping the playback, there are no errors.

Everything works properly on screen.


Solved it – and by the way, I realize now it was slowing down the scene considerably.

It was simply that I made a call from OnGUI to a function called Login. Since it’s in OnGUI, it was called every frame, when only once is all that is required or desired. The Login function made calls to functions containing the WWW class, and so there were many, many WWW download threads running simultaneously.

Solved it with a simple boolean thus:

if ( loginNotSent ) Login();

And of course within Login() there is:

loginNotSent = false;

The double negative is a little confusing, but anyways, it works. Hope this might help others someday.