Tile Palette off-center for any sprite assets not using center pivots

If my actual sprites have a non-center pivot (for example, I use bottom pivots), the Tile Palette does not display my tiles correctly. They are offset from the grid. The tilemap anchor can be changed (0.5, 0, 0 for bottom pivots) and the actual tilemap tiles are displayed correctly. Here is an example of what I mean.

I use bottom pivots because my game is a top-down Zelda-like and it makes sense for all of my objects (at least my game objects). When 2D sorting is re-implemented in the tilemap, I'm assuming that it will work around pivots so I'd like to keep using bottom pivots for now.

11 Likes

Sorry to bring this back, but I'm currently suffering from the exact same issue. Did you ever find a solution?

1 Like

You can edit the Tile Anchor of the Tile Palette by:

  • Selecting the Tile Palette asset in the Project Window
  • Opening the Tile Palette in Prefab Mode
  • In Prefab Mode, select the Tilemap component of the Tile Palette
  • Make the appropriate changes
  • Save the Tile Palette instance changes
11 Likes

I did the steps mentioned above, but it doesn't help.

In the tile-palette the grid looks fine:
6404169--714645--upload_2020-10-10_15-26-7.png

But in game when I try to add it, it adds it off-grid
6404169--714648--upload_2020-10-10_15-26-41.png

@asaf92 You will need the same Grid settings as the Tile Palette for the Grid in the Scene. If that is not what you want, you can instead change the Pixels per Unit value for the Texture of the Sprite to ensure it fits well in the scene.

I followed ChuanXin's steps to edit the Tile Anchor of my Tile Palette. (Step 1)

6495919--730861--Tile Palette Anchor.png

Then I realised I had the same issue as yours. So I went on to change the Tile Anchor of my Tilemap (Step 2) as what ChuanXin suggested and it works. Does yours work now too?

6495919--730879--Tilemap Anchor.png

P.S. I changed my Tile Anchor to (2,2) but I guess it varies based on different tilesets.

1 Like


Im not the OP but this worked for me!

1 Like


Awesome! That's great to hear! Thanks for letting me know. :smile:

Thank you so much! worked for me

It doesn't seem to have a tilemap component