Tiled sprite with auto tiled 2D polygon problem

So I have this issue where I’m hitting the spikes even when I’m far away from them and I can clearly see the issue comes from the sprite renderer draw mode being tiled since changing it to sliced works fine but visually isn’t what I need. It’s set up like this so I can have the walls and spikes move and scale as I need it.
I’ve tried playing around most settings and reset the 2D polygon collider after changes but couldn’t find how to make it work properly.

Anyone knows a way to fix this?
thanks.

172976-wallspikes.png

For anyone curious, found a roundabout way of fixing it just separating the spikes colliders and sprite visuals into 2 different object, tiled for the art and sliced for the colliders, fairly weird and simple fix but works well.