Tilemap and palette bug

Update: I just fixed it. I missed to set Mode from “Chunk” to “Individual” in Tilemap Renderer component both in grid and palette.

I have built a tile set of 293x293 pixels.
I imported and sliced it accordingly, I know all those things. But when I created a tile palette a weird bug (or glitch) showed up.

As seen in the screenshot, palette shows a weird glitched image. And when I move mouse pointer on the palette this glitch animates. When I select one of the unseen tiles on it and try to paint on the scene the appear pink like that.

I have this on 2018.3.0 and 2018.3.14 versions, even tried 2019.2 beta version, still the same damn thing. Stuck on the whole thing I do here.

What might cause this to happen? Is it something on my end? Or is it a common bug?

I’m facing the same issue on 2D platform game project in 2019.1.0f2. From my quick research it’s a bug that has not been fixed since 2016. Seriously???

Actually you should choose “Individual” instead of “chulk” in somewhere I can’t remember now. And must do this both in Tilemap in the scene and also in the pallette view. So this is fixed like that. But yeah, chulk mode is bugged.

Changing “Chunk” to “Individual” mode didn’t work for me - the Tiles displayed properly in the Scene, but still without change in Tile Palette. Somehow, after ~2 days of trial and error I managed to fix it by disabling (removing) PSD Importer 2D and IK 2D packages from my project → recreating palette and then installing the packages again. Everything works smoothly by now.
I suppose it’s some strange bug with 2D tile grid itself.