tiling texture become dark in far

I want to have a green grid in a plane and I do following:

  1. Create a plane and set scale to 100
  2. Create a custom material with “Unlit/Texture” shader
  3. Choose the texture and set tiling to 100
  4. Apply material to plane

But as the screenshot below, the green grid become dark in far. It’s not affected by light because shader is Unlit.

How Can I set all green grid have the same brightness???

Thank you very much!

It looks like it’s mip-mapping.

By default, when textures are imported Unity generates a sequence of lower-resolution versions of them to be used in the distance. In this case, as the resolution is lowered the green pixels and black pixels get blended together with the result that it gets darker.

If you select the texture in your project, then in the import settings change the Texture Type to “Advanced”, you can play with the Mip Map settings. Try disabling the “Generate Mip Maps” option to start with to confirm that’s the problem. If it is, either leave it turned off (which might look nasty), or play with the mip-map and Aniso settings to see if you can find a compromise.