Timeline Audio Source problem using Cinemachine

Hi guys! :smiley:

So I’m working on a project at the moment and I ran into a problem I can’t figure out for the life of me. I’m using Cinemachine and Timeline to create a dramatic entrance to the scene and I’m trying to sync the music rhythm with camera cuts and other transitions. I noticed that as the camera moves, the music will pan as if the music was 3D. Here’s what I’ve checked so far:

  • Audio listener and audio source are at the same position (at the moment they are separated into different game objects, but I’ve tried attaching both to the camera with the same results)
  • Timeline track’s audio source is set to the previously mentioned audio source
  • Audio source component’s spatial sound parameter is set completely to 2D
  • Only one audio listener
  • At the moment there is an audio mixer attached, however removing it yields the same results
  • Played around with the “spread” and “distance” parameters of the audio source; no change
  • Audio source is playing ONLY through the timeline; “play on awake” is disabled
  • Bypassing effects doesn’t fix it
  • Changing the audio sources’ assigned “Audio Clip” doesn’t seem to make a difference

Since I’m using virtual cameras, the “real” will move around the scene depending on which virtual cam is active at the moment, however, the audio always plays from the same position (still trying to narrow down exactly what the common factor is in regard to the position the audio is originating from)

I’m sure this would be no problem to do through script, but I was hoping for the graphical precision that timeline offers for sequencing. Maybe this is a lack of understanding on my part, but does anybody have any ideas? Thanks for the help!

See all this weirdness:

https://forum.unity.com/threads/audio-in-timeline-is-not-respecting-2d-vs-3d-audio-source-values.496108/