Timeline AudioTrack stuttering and artifacts

I'm playing an audio clip from the timeline, but it has clicks and pops, like stuttering in play mode. If I trigger the same audio source manually the clip plays fine. The speed is set to 1 and all other settings are just the defaults. The clip itself has no compression etc, and as said, it sounds normal when I play it by triggering Play on the source from code.

What could be a reason for this? Anybody else have problems with audio in timeline?

Do the clicks and pops go away if you set the Time Update Mode on the playable director to DSP Time?

No, different time settings change the artifact pattern, but it's still there. Not sure if I can reproduce this as a bug, since it doesn't happen in a clean project and only with some clips.

I've tried to recreate the audio track and add the clip fresh, then it appeared to sound fine, but after a while I noticed the issues again. Maybe it's something with the import settings or with the file format of the source clip.

I might have clue after some testing:
The issue happens, when the playing AudioSource component has a volume, that is not 1. If I turn it up, all fine, if I lower it to 0.3, the clip sounds as if it had an echo (I can hear the beginning played twice in a row), but when setting the volume to 1, it sounds normal. (And I've made sure there are no duplicate timelines or anything like that.)

Update: I recreated the clip track once more and had a totally different sound issue: the source volume was ignore, but instead my clip was panned from left to right while playing. So, I just noticed, that my clip was stereo (and probably shouldn't be), and it has very erratic behaviour when played via timeline.

This issue is still present in 2017.2.0f3. Stuttering gone when AudioSource volume is set to 1.

This is still a problem as of the 2018.2b7 beta build. Did anyone submit a bug?

I couldn't locate any in our Bug database. Can you open an issue with a small repro project? also you can post the bug ID here in the thread, it will be easier for us to track it down.

thanks!

I had already worked around the problem, and when I tried to go back to the broken state, couldn't repro. If/when it crops up again, I'll open the issue and post the id. Thanks!

1 Like

Hey guys, this is still an issue for me. Has the bug been reported in the database? Otherwise I can go ahead and make a little example project for the issue


Please report it!

1 Like

@angusmf I guess that means the issue has persisted for you as well. I will report it


Haven't seen this issue for a while, but that doesn't really make me rest any easier. I'm not sure what I did to "fix it." Anyway, just my opinion, but if you can reliably reproduce any bugs, they should always get reported. Helps everyone. :)

Im having the same issue. Finding a lot of these issues in unity, nothing ever seems to get fixed. It's like the audio is in slow motion when playing the timeline clip. Not very nice when you are trying to place markers/signals to the tune of an audioclip. Btw, another issues I read about. Getting custom colors for markers/signals. it was promised to do in an upcoming fix, but so far haven't seem them either

still happening in the latest version of 2021, what the hell? any clue how to fix it? or a workaround?

Yeah, I'm seeing this too. Still no fix?