Timeline bug unity 2019.4

I’m kinda new to using timeline but I’ve used it in the past on past projects and it was very streight forward, now i’ve updated to 2019.4 and using it for the first time in a while

so I want to but able to very simply create this timeline where i move 1 gameObject from point A to B
I created empty object with sprite (lets call it sprite1)
I created empty object to sit Timeline and added a playable director to it
I created new timeline on assets and dragged it to the playable director slot

Oppened Timeline window dragged sprite1 to the timeline window and was given the option to add animation track, done so and the pressed record button: ERROR
"NullReferenceException: Object reference not set to an instance of an object"and then a bunch of error lines like:


UnityEditor.EditorWindow.RefreshStylesAfterExternalEvent () (at <1fe7a3c0284a456b9681b7a93141c89a>:0)
UnityEditor.AnimationMode.StartAnimationRecording () (at <1fe7a3c0284a456b9681b7a93141c89a>:0)
UnityEditor.Timeline.WindowState.set_recording (System.Boolean value) (at Library/PackageCache/com.unity.timeline@1.4.4/Editor/State/WindowState.cs:228)
UnityEditor.Timeline.WindowState.ArmForRecord (UnityEngine.Timeline.TrackAsset track) (at Library/PackageCache/com.unity.timeline@1.4.4/Editor/State/WindowState.cs:881)

etc etc

I tried adding an animator to sprite1- no difference (if i add a clip to timeline it works though but thats not what I want)
I tried updating Timeline packages- nothing
I’m thinking about downgrading to 2019.3 to test but i’m afraid of loosing my project so far…

help?

This is a known issue, and there is a fix in Unity 2019.4.15f1 and above. When this happens, you can also work around the issue by refreshing your Layout.

thank you. couldnt find similar queries, will update and keep refreshing layout.