Timeline just stops when I animate a camera. I am desperate!

I have a simple camera without Cinemachine.
I move the camera from point A to B with an animation track on its transform.

Behavior in editor: Works fine

Behavior in play mode with option "Maximize on Play" ON : Complete timeline just stops (pauses?) during the animation track (a bit over the half)
7121380--850336--upload_2021-5-8_19-6-30.png

Behavior in play mode with option "Maximize on Play" OFF: Works fine

I muted and unmuted all other tracks and so i am 100% sure it's the camera track. When i don't try to move the camera it also works.

Can someone please tell me what the issue can be? I really don't know what to do now to animate this camera.

Impossible to tell with just this description.

Please file a bug report with your timeline, and paste the bug number here. We'll look at it early next week and figure out what the problem is.

Actually, before that, check that the Animator on your camera is set to Always Animate.

[quote=“DavidGeoffroy”, post:3, topic: 840114]
Actually, before that, check that the Animator on your camera is set to Always Animate.
[/quote]

Ok i found the issue, it was a combination of two animation tracks. I don’t know if this is a bug or this behavior is intended.

7121948--850400--upload_2021-5-8_23-56-5.png

The Animator of the camera is set to “Always Animate” .
The Animator of the blue butterfly blob (round light blue body ball) is set to “Cull Completely”. There are many blobs in scenes so i set this to save performance and a blob is a prefab.

I have an animation track for both the butterfly blob and camera:
7121948--850403--upload_2021-5-9_0-0-19.png

The timeline freezes as soon as the blob body is out of view:
7121948--850409--upload_2021-5-9_0-1-55.jpg

So the fix is to change the option on the butterfly to “Always Animate” for the timeline.

It worked in Editor Mode and in Minimized Gameplay mode because the butterfly was still visible in the editor window then.

I have a fix now, but it feels like a bug. Shouldn’t the timeline just continue and only stop animating the butterfly when it’s body is out of view?

Normally one animator being culled shouldn't have an impact on the rest of the Timeline.

But any number of things could cause this, and this is why the best for us is to have a look at the scene itself to see if it's a bug in Unity, or a combination of systems causing it.

We would really appreciate a bug report

This also solved it for me. Which I thought was weird because I didn't have this problem before. Turned out it was (probably) because I had animation clips for that object during the period it was inactive. Muted the animation track and there were no problems.

Same issue here, unfortunately no time to file a report at the moment.

When an animator with Cull Completely is inactive but a timeline animation crossfade gets sent to it, the timeline playable seems to break entirely. It stops progressing, scrubbing no longer affects it, there is no error/warning logged, and this only happens in play mode.

Setting the animator to Always Animate fixes the issue.