Timeline not playing with cinemachine tracks on it

I'm trying to blend to a timeline that has a dolly path that has the path position animated over timeline. When I run this playable director in the editor, it works great. When I add my event that ups the priority of the vcams involved in this dolly path and then play the timeline, it will usually switch to the first vcam in that timeline sequence when it's supposed to, but just not play the timeline; the camera just sits there. I am using the gameobject.GetComponent().Play() to run the timeline and then just upping the priorities for those vcams over my player's control vcam to do this. Where am I going wrong?
Play on awake is set to false... that's the only other thing I could think of atm.

Hi,
this could be indeed a bug.
can you please open a bug with a shared project. Also paste the bug number here so it is easier to follow.
Thanks!

Not sure if it is related, we're experiencing an issue where we're using a Cinemachine Track, populating the contents dynamically when they are instantiated ( CM RC 6 + 2017.2.0f3 ). In the editor, it all works flawlessly - camera pans and targets as expected. On device, rarely, it just stops working completely, almost like some fix up or guid has changed perhaps? The worst part is, it seems work about 95% of the time..
When we upgraded to RC6 Cinemachine, it all seemed to fix itself again then 2 weeks later the issue came back.
The problem is trying to debug it, when on a device with full debug, timeline/cinemachine says everything is setup great yet the virtual camera never animates.

I'm not sure if it is related to the assetbundle issue that was fixed in 2017.3, we're testing the beta shortly to confirm...but don't feel 100% confident as this seems to keep popping up at the most inconvenient time.

Any ideas to confirm what the exact issue could be on device?

thanks

@FALLENxGaLaXie5 that does sound like a Timeline bug

@KB73 we are looking into this. CM RC7 will shortly be out and with a fix for that hopefully.

If it still happens with RC7+ please let us know on the Cinemachine forum, thanks!

1 Like

I tried RC7, no luck unfortunately

I think it maybe more due to there are 2 timelines playing around the same time and both are trying to get control ( they do have the same priority ) but changing the vcam in the priorityqueue via the MoveToTop function didn't net any changes.

I am just a bit confused as to why it will work fine in the editor and not in an assetbundle off a device. There are several other timelines in the rest of the app and they all work seamlessly.....

I'll keep digging to get more information.

thnx

Ok resolved. This was our side, basically we had a timeline A and a timeline B starting at a similar time on the assumption A was setup first then B, they both had the same priority system but A was initialized via an async call.

My workaround for bumping up the priorities on timeline B didn't seem to work so i assumed something else was an issue. I still need to look into this aspect.

Anyway the async in certain situations forced B to set up first then A and as a result we had the other timeline overriding due to the cinemachine behaviour re: virtual cameras with similar priorities set up based on order in which they are enabled/activated.

Hello
if anyone experiences the same issue in the future:
make sure you have only one camera component for all your virtual cameras driven by the same brain.

cheers