timestamps but is not known in guidmapper...

My project crashed and when reopening i get the error “timestamps but is not known in guidmapper…” for every asset in the project. I searched around and found a couple ideas ranging from activate the project wizard to pressing alt when loading…nothing worked. I chose reimport all assets and it brought everything back in but EVERY single link from materials to textures, scripts, atlases…Im mean every link is broken…I’m sweatin here…put alot of time in. Hopefully there is a fix.

any help would be great!

please delete the directory named “Temp/” and “Library/” in your project!

Hey Everyone, if you go to “Assests” in the editor, and go down to “Reimport All”, it will fix all the errors, and keep everything in your game just the way it was. The perfect, easy, and harmless solution.

Hello!

I don’t know if you’ve finally found a solution for this, but my best solution was removing the files from the asset folder, that couldn’t be found. Then adding them again. I got this error when moving project to skydrive and opening unity when sync wasn’t finished.

If you just delete the metafiles dir and try opening the project again, Unity will import all assets again with pretty much good results. you’ll have to manually do a few thing but its not too much trouble.

Hi, @Lukas_GMC @mybrainhurts @NineNineFive
In my case this error was caused by a syncing process (Google Sync or Google Disc). So, when I moved the file from Google Disc to another folder project worked fine. I think that was because the files were reserved by syncing app and Unity didn’t have access to the them… as a test you can try reopening the project after the syncing process is finished (but whenever you make a change and try to save it, it will again show you the error). So:

  1. Try to switch off syncing for this folder.
  2. Move the file to another folder and if you want to sync it in Google Disc you can put it back after finishing your work.
    Hope this will help. Thank you! :slight_smile: