tizen.bat doesn't work on Windows?

Trying to set tizen up on Windows. Everything went fine until I needed to run the "tizen.bat" terminal command.
The error doesn't make any sense as it should be working...

I get the error: Error: configuration must be specified in the form:=

Here is that command run:
PS C:> .\tizen-sdk\tools\ide\bin\tizen.bat cli-config "default.profiles.path=C:\Dev\Test\TizenWorkspace.metadata.plugins\org.tizen.common.sign\profiles.xml"

Error: configuration must be specified in the form:=

Usage: tizen cli-config [args]
= Setting Tizen CLI config with given key=value pair
In Windows ,the setting values should be enclosed with
doublequotes like as "="
-- working directory Specify where the base directory is for the command
--global (-g) Setting global Tizen CLI config
--list (-l) Show config list
-h (--help) help Show detailed explaination for given command
PS C:>

Now I can't Tizen to work in either Windows or Mac...
I'm on Windows 8.1. TizenSDK 2.3.0_rev3

Here is a suggestion. Why not just let us give a direct path to the "profiles.xml" file within the Unity setting? Problem solved I would think.

[quote=“zezba9000”, post:1, topic: 590065]
Trying to set tizen up on Windows. Everything went fine until I needed to run the “tizen.bat” terminal command.
The error doesn’t make any sense as it should be working…

I get the error: Error: configuration must be specified in the form:=

Here is that command run:
PS C:> .\tizen-sdk\tools\ide\bin\tizen.bat cli-config “default.profiles.path=C:\Dev\Test\TizenWorkspace.metadata.plugins\org.tizen.common.sign\profiles.xml”

Error: configuration must be specified in the form:=

Usage: tizen cli-config [args]
= Setting Tizen CLI config with given key=value pair
In Windows ,the setting values should be enclosed with
doublequotes like as “=”
– working directory Specify where the base directory is for the command
–global (-g) Setting global Tizen CLI config
–list (-l) Show config list
-h (–help) help Show detailed explaination for given command
PS C:>
[/quote]
The message doesn’t lead you to think this is the solution but try running the command from inside a Tizen project folder such as one that you created with the Tizen IDE. It sounds strange but it works.

As for the suggestion of providing the path to the profiles file: I’m working with Samsung to try to get that set up automatically for you.

Same error. Didn't seem to help unless I misunderstand. I "cd" into my workspace where the ".metadata" folder lives, then run the command. I tried the full path of the profile.xml and relative, doesn't change anything.

By project folder do you mean workspace folder??

[quote=“zezba9000”, post:4, topic: 590065]
Same error. Didn’t seem to help unless I misunderstand. I “cd” into my workspace where the “.metadata” folder lives, then run the command. I tried the full path of the profile.xml and relative, doesn’t change anything.

By project folder do you mean workspace folder??
[/quote]
No, by project folder I mean a project folder. For example create a project using the Tizen IDE. You’ll see a new folder in the workspace folder. cd into that new folder.

Ok that works but Unity still doesn't work. I did as you said and it completed succesfully but Unity still gives the same error.
This didn't happen on mac but mac doesn't build valid tpk files.
NOTE: On both Windows and Mac the Tizen IDE builds and uploads tpk files without issue.

I get this error in Windows which shouldn't be valid anymore:

Should I just wait for the next patch release to try again? So far Tizen support doesn't seem to be quite ready in Unity. Or i'm missing something but don't see what it could be at this point.

Unity 5.1.2p1 works on Windows correctly!
Build&Run doesn't upload the tpk file to your device though.
Use this terminal command to do that: "C:\tizen-sdk\tools\sdb.exe install pathTo.tpk"

[quote=“zezba9000”, post:7, topic: 590065]
Unity 5.1.2p1 works on Windows correctly!
Build&Run doesn’t upload the tpk file to your device though.
Use this terminal command to do that: “C:\tizen-sdk\tools\sdb.exe install pathTo.tpk”
[/quote]

5.1.2p2 its not working I tried it yesterday, How did you get it working? Unity should make it possible to build for the emulator too…

[quote=“meapps”, post:8, topic: 590065]
5.1.2p2 its not working I tried it yesterday, How did you get it working? Unity should make it possible to build for the emulator too…
[/quote]
What is the issue that you’re running into? Have you double checked that all the steps from our setup docs were followed correctly?

Yes I will try today again. I wish or request an video tut in future and more infos and support for tizen.

[quote=“meapps”, post:10, topic: 590065]
Yes I will try today again. I wish or request an video tut in future and more infos and support for tizen.
[/quote]
What would you like to see for more info and support? I’m open to suggestions for improvements.

More links in the doc and video tutorials to help developers to build and publish games easier.

[quote=“meapps”, post:12, topic: 590065]
More links in the doc and video tutorials to help developers to build and publish games easier.
[/quote]
I’ll look into video tutorials. Any specific topics or tasks? More detail will help me out a lot.

What do you mean by more links in the doc? Links to what?

yesterday I forgot first to download the Tizen Extension SDK for Certificate for example. Add an link to the doc. There is also an video on youtube where to find it also how to create an certificate for tizen.

[quote=“meapps”, post:14, topic: 590065]
yesterday I forgot first to download the Tizen Extension SDK for Certificate for example. Add an link to the doc. There is also an video on youtube where to find it also how to create an certificate for tizen.
[/quote]
That’s actually step 2, with a link, in the setup docs :frowning: http://docs.unity3d.com/Manual/tizen-setup.html

Right where you download the setup extension there is a link named Getting Started. Sounds like what you were looking for. http://developer.samsung.com/technical-doc/view.do?v=T000000198

I give up for now. I will try it next week again. Its just an terrible experience if it dont works:(

Now i got an different error: 2235597--149031--2015-08-04 19_18_47-Unity Personal (64bit) - Untitled - QuarthLatest - Tizen _DX11 on DX9 GPU_.png

2237354--149192--2015-08-05 20_09_08-Preferences.png Got it working the problem is if the Security Profile was not setup in the preferences right. Author Certificate needs to be setup right.
Please unity add more step by step doc to the documentation. This was a nightmare to setup!

[quote=“meapps”, post:18, topic: 590065]
Got it working the problem is if the Security Profile was not setup in the preferences right. Author Certificate needs to be setup right.
Please unity add more step by step doc to the documentation. This was a nightmare to setup!
[/quote]
Sorry that it was such a hassle. From just the screen shot I don’t know what was wrong with your setup. I’d be happy to improve the documentation but I’ll need more information. Could you elaborate on what the problem was and how you resolved it?

Your doc dont covers the setup of the profiles. You need to setup the signing profile in the security Profile setup to get it working. And the name is only default if you call it default. Everything needs to be explain step by step.

It must also be possible to load the tizen project in the IDE. Instead of building it. There are only one phone available and testing it on an emulator is necessary.