Tracking not working for both controllers at the same time on Oculus Quest build 7.0

Since the last update of Oculus Quest (to build 7.0) I can’t move both controllers at the same time in my Unity builds:

  • It’s only being tracked the “active” controller

  • I can switch active controller by pressing the trigger of the controller I want to set as active

  • This is only happening in builds of my projects in Unity, tracking of both controllers works great with Oculus Quest applications (Home, YoutubeVR, JobSim, etc.)

Video showing this behaviour
(Lightweight VR RP default scene. It’s the same behaviour with VRTK example scene)

Someone else is having this problem? What could be the cause?


I am having the same issue, just that it is a bit worse on my side.

After the Oculus update, except not seeing both controllers at the same time, it seems like the OVRControllerHelper script, from OVRControllerPrefab does not recognize anymore the OculusTouchForQuestAndRiftS Prefab which is set as a reference. It always sets the one for Oculus Go. Besides not seeing the Quest Prefab during gameplay, it seems that also the movement of the player is affected, which was controlled from the joystick.

I think the Oculus Integration Asset from the AssetStore needs a new substantial update!

If anyone out there is still having this problem after doing the solution provided (It didn’t work for me when I tried) I find a solution that worked for me on the oculus forums. Here are the steps:

Open AndroidManifest.xml

Navigate your cursor in between and

Add These two lines of code:

<uses-feature android:name="android.hardware.vr.headtracking" android:required="true" android:version="1" />
  <uses-feature android:glEsVersion="0x00030001" />

save & build

Got both my hands appearing right after building again.

Hope this helps somebody out there.

So, I followed all the comments above, It somehow did not work for me. Unity was giving me an error called as ‘Check the console settings properly’
So I kept playing around and changed 2 settings in OVRCameraRig

  1. Made Element 0 as ‘Quest’ which was ‘Gear VR’ before
  2. Changed the Tracking Origin type to ‘Floor Level’

Somehow it worked for me. :slight_smile:

I am having a similar issue. It looks like the Oculus Integration plugin was updated to version 1.39 on July 26th, which I assume was updated to work with build 7.0 for the Quest, but there is no mention of this in the release notes (

I was going to update to the latest plugin, but there is a stream of reviews saying it caused a lot of issues and to return to version 1.38. Not too sure if this is your answer or of any help. Just found you struggling with the same thing I am and thought I’d share.


(In Unity project)

  1. Oculus > Tools > Remove
  2. Oculus > Tools >
    Create store-compatible
  3. Rebuild

Check comments bellow if this solution didn’t work for you

I am loading my via adb and the command prompt. If I build it in my project folder and then move it to my adb folder should the manifest change still work? Or does it need to stay in the same relation?