Transform "Armature" not found in humandescription.

Basically, i made an character in Magicavoxel, rigged it using Mixamo auto-rigger and downloaded some premade animations to it and everything was working fine. Then, of course i also wan’t my own custom animations, so i imported the rigged character into Blender and made my first animation.
I exported the animations into unity and the problem appears when i changed the animation in to humanoid, pressed “Copy from another avatar” and chose the original character avatar.

I went to the animation tab and found that there was an import error message saying: “Copied avatar rig configuration mis-match. Transform hierarchy does not match: Transform “Armature” not found in humandescription”.

I dragged the custom animation and the premade animation in to the hierarchy and found out that the custom one had an extra gameobject called “Armature” which was an parent to the root bone (Hips).

Is it possible to export an animation without the “Armature” in blender?
If so, please tell me.

Try to change animation type in import settings from humanoid to generic and then back to humanoid again, then recreate avatar (Create From This Model option). Worked for me.

I have the same error.Please someone help!,I got the same error. Please someone answer :frowning:

Hey, Im having the same problem can anyone tell me wich bone to remove in Blender?

I had the same problem and was not willing to re-export all my animations just to accommodate blender’s janky hierarchy system.

After looking all over, I’ve found that someone made a custom FBX exporter addon for Blender that doesn’t export the extra “ghost bone.” Absolute lifesaver.