transform find with tags always return null

Hi, I know that my question has been asked by other people, but I have tried to read those post but still can’t solve my problem so I decided to post my own question. I tried to get the Animator components from a a child of a child using the code on the attached image. But it always return null reference object reference not set to an object bla bla… I already have the workaround using the commented code (ignore the wrong variable name) but I still want to know why I got those errors since I am still learning Unity. Thank you 135826-2.png

transform.Find uses a string to find a child. The LookRoot string is fine but the FPCamera string doesnt have a space in it while your gameobject does.

To debug this, try spreading it out. First get the lookroot object, debug the transform to see if you found it. Then get the fpcamera from that and debug again. In that case it would return null. Then the problem is in the second Find().

Also spreading things out makes it more readable