Transform offsets different in play mode?

Hey maybe someone can enlighten me and this may be my own ignorance with timeline and offsets generally. But why would my transform offsets manifest differently in editor vs playmode? I have tried everything to reset the playmode offsets.. reset offsets, use scene offsets, transform offsets, delete and re-enable the transform reference, mute unmute etc. but nothing gets me to my editor offset. Seems like the only thing that might help is just deleting the track and starting again but surely this is unintended right?

This problem is totally inexplicable to me I cant understand why it would be different.
Editor mode:
9661988--1375727--upload_2024-2-24_10-43-29.png

play mode:
9661988--1375724--upload_2024-2-24_10-43-15.png

I cannot explain from first principles why this works but one of the tracks had it's "remove start offset" disabled. I re-enabled this and just re-recorded the track and its fine now. I will just re-record stuff in the future I think it overall saves time than trying to debug it.

Timeline continues to plague me. Offsets in playmode just arbitrarily different to what I distinctly record in editor with scene offsets. Lots of attempts to record with fresh characters, infinite clips, clip tracks/transform and scene offsets.

I have a character perfectly set up. everything works in editor. The infinite clip adds 80 onto the y axis on the first frame and 0 on the last frame (i.e. I want my character to land in a particular place). In play mode the last frame is at -80 on the y axis. Why is it doing this.

Offsets are touchy, hints : check your animations, individual animation offsets in timeline, root motion, use a parent transform to move character around as animations will override character root. If you want a specific position better use transform offset than scene.

1 Like

You are CORRECT they ARE touchy! One more thing I discovered which is interesting and can't imagine is intended, if you have scene offsets enabled and you go into play mode and halfway through the animation you decide to scrub the sequencer timeline back, the scene offsets will use the newly moved offsets from wherever you left the animation, such that they have a stacking effect. This becomes persistent even after you exit playmode and I've had to sometimes remember what my original offset was so I can type it in again. Sorry I'm not really looking for more advice just noting, that despite unity being an amazing tool, sometimes it is a clusterfuck quasar of arse backwards pisstakery.

I just discovered the infinite stacking transform offset and came to the forums to see if this happens to anyone else. This is a huge issue and honestly prevents most of Timeline from working at all. Have you found any fixes to it.


What do you mean by infinit stacking, Did you try changing the Timeline Modes (Hold / None / etc) ?

It will continue to add to the transform position as you scrub back and forth in the timeline without reverting back outside of preview mode.


Scene offset will use the offset of the element in the scene at the moment the timeline binds the elements. Transform offset will use the transform offset specified in world space. (I actually did implement my own version of local space Transform offset as we dynamically instantiate timelines and needed the timeline to dynamically apply its own position and not a fix offset). However it seems to me that in your situation Transform offset should work ?


That is indeed a strange behaviour. Didn't notice it myself (might have but not recently :smile:). Do you have an example of your setup ?

No fix other than try to use Transform offets when you can. This is the first time I have tried to construct a cutscene of more than a minute so maybe people just don't use timeline that much to notice this stuff but it really is borked all over the place.

I sometimes uncheck "remove start offsets" as well and adjust using those values but they also often don't reflect in playmode. My working assumption is that things get corrupted as time goes on so the easiest thing to do when you start noticing this behaviour is to delete the connection from your source prefab to the timeline track, select the track and reselect "apply scene offsets," then re-pair your prefab to the track. Failing that just delete the animation and re-record. Sorry I have no other advice other than take it up the tailpipe like all the other unity using masochists (jk I love unity really)