Transparency from Blender to Unity. How to do it?

Hi. I’m currently working on a game where I need a transparent tube with three colors on it: yellow, green, and red. I want the player to be able to see the ball go through the tube as the colors light up to the balls corresponding position. I made a model in Blender that consisted of three separate cylinders lined up together, their end faces deleted, then the tubes solidifyed, each given a Z-transparent material (Alpha and Specular both at 0), and lastly smoothed out. In Blender the render preview shows that the model will be nearly invisible. However, when I import the model into Unity and make the materials have Transparent/Diffuse settings, while the tubes look perfect, they also get solid faces on their ends when viewed from an angle. When I look straight down the tube there are no end faces, but at an angle I see them in both the editor and game camera view. Why are these faces there and how do I get rid of them? Is this a Unity problem or a Blender one? Is there a better way to make a model like this? Here’s a screenshot of a view of the model in the Unity editor and game preview.

If you need any more information, just let me know and I’ll try to get it to you (not sure if that’s possible here).

Looks like just a lot of simple modelling problems. There’s a lot more to learn that you’d think for modelling+exporting for games. I think the real answer is: if you haven’t exported and used 30+ different models, over a few months, don’t expect to be good at it.

Just looking/reading:

o Don’t even bother setting up materials outside of Unity. You’ll have to redo
them in Unity, anyway. Easier to just make them all in Unity to begin with.

o Looks like a flat/smooth shading problem (diagonal light/dark line on the sides.)

o Comparing to the lighting on the sphere, the normals may be backwards.