Tree Creater won't render mesh leaves.

I know this question had been asked before but it hasn’t been answered; as far as I know. I just got started in tree creater and it is very useful. One problem I’m having is that when I choose mesh leaves and select the mesh, a leaf I created in blender, it loads but there is no leaf showing. I manually put the leaf material over the optimized leaf material that was there and it showed the leaves but they were all over. None were in contact with the tree. I’ve made trees in blender so if there’s no fix I’ll survive but this tool is very helpful. One more question. Can you sell the trees you make with the tree creator on the asset store. Thanks.

Hi Baldinoboy,

Check out this tutorial, I think it will answer most of your questions.

TreeCreator Tutorial

Zaffer

I had some of the same issues: Mesh not appearing, or oriented the wrong way… but I’ve found a solution that worked for me:

When your meshes aren’t appearing, even when applied, likely the issue is that the mesh you want to use is hidden within the import mesh. You may need to expand the mesh/object item to show it:

[26257-screen+shot+2014-05-06+at+1.43.50+pm.png|26257]

In my case, I had to use the mesh called ‘Default,’ shown here as the third item, and not ‘LeafDome1_opt’ that reflects the name of my file. Selecting this inner mesh worked!

Secondly, you may need to re-orient your mesh within your modeling software:

  1. Ensure that the mesh’s center and pivot are located where you want your leaf mesh intersecting with your branches.
  2. Rotate your leaf mesh (within your modeler) to stand upright from the origin. The new ‘up’ direction of my leaf was interpreted as the Z axis within Unity, with the top of my leaves facing into the screen (pos Z direction)
  3. Export mesh and import again.