Tree Soft Occlusion shader makes trees invisible in editor

Hi all. I imported a tree model from blender as .fbx to ‘Ambient-Occlusion’ folder in the ‘Assets’ root as Unity documentation suggests. 2 materials were successfully generated and I assigned ‘Nature/Tree Soft Occlusion Bark’ and ‘Nature/Tree Soft Occlusion Leaves’ shaders and appropriate textures to them. Unfortunately this makes my .fbx model invisible either when I place it directly to the scene and when I use it as tree in Unity terrain trees system. When I running the game mode trees placed with Unity terrain trees system becomes visible But fbx which were directly placed still seems invisible.
I noticed strange things when trying to play with built in Unity tree. It also has ‘Nature/Tree Soft Occlusion’ shaders but they seems not the same shaders as I can select in shaders menu!

As you can see checkbox of ‘Nature/Tree Soft Occlusion Leaves’ shader not checked. If I check it the appropriate material of palm tree also becomes invisible exactly as I described above for tree model imported from Blender.
As additional information I can say that project was originally created in Unity 4. So problem might occur when importing to Unity 5. What I’m doing wrong and how can I fix this?
Thanks in advance.

Had the same problem because trees need to use the Tree Creator shaders. When you use another one, Unity creates an optimised material from the wrong shaders. So you need to remove the optimised materials and add the correct materials to your branches and leaves. Hope that helps