Troubles with Skeleton Tracking SDK for Intel Realsense from Cubemos

Hi there,

at the moment i have got a trial version of the Skeleton Tracking SDK to figure out if its working as expected. I have ordered the realsense D435 camera and tried to get the Skeleton Tracking SDK running in Unity3D (2018.4.11f1). But i always get two error messages

  • “DllNotFoundException: realsense2”
  • “RealSense pipeline not initialized!”

I tried the troubleshooting as explained in the added pdf.

  • Rebooted System … Nothing changed
  • CUBEMOS_SKEL_SDK with the Path C:\Program Files\Cubemos\SkeletonTracking was already inserted to the systempaths so i additionally added CUBEMOS_SKEL_SDK\bin with the corresponding Path C:\Program Files\Cubemos\SkeletonTracking\bin
    This did not change anything, too.

I have to mention, that the unity wrapper examples from realsense work. The exe files in the Cubemos Skeleton Tracking SDK bin directory are working too (when i start dem from the explorer). The realsenseviewer from INTEL is also working without any problems as far as i have tested it. I followed the installation instructions in the Cubemos Skeleton Tracking SDK Getting Started PDF, run post_installation.bat and followed the step with the result of “success”.

I really do not know what to do next.
Can you please help me out and give me any advice to just get into testing this camera?

Thanks in advance,
Christine

P.S. i am on win10 x64

Were you able to get the Cubemos SDK to work?

What I was experiencing was:

  • the Cubemos SDK worked in the Unity editor
  • it did not work when I built and exported a Unity Windows app & ran the Unity Windows app.

The solution was to copy all the DLL’s from the Cubemos C:\Program Files\Cubemos\SkeletonTracking\bin folder to the same folder as the {Some Project Name}.exe.