Trying to change material alpha cutoff from code fails

I’m trying to create materials from textures in editor. Everything works on paper, but the alpha cutoff doesn’t update in the material itself. Inspector shows the right value but when entering playmode the alpha isn’t transparent. Here’s the code:

[MenuItem("Assets/CREATE MATERIALS FROM TEXTURES")]
    public static void Convert()
    {
        Texture[] textures = Resources.LoadAll<Texture>("");
        foreach (Texture t in textures)
        {
            Material material = new Material(Shader.Find("Standard"));
            material.SetTexture("_MainTex", t);
            material.SetFloat("_Mode", 1.0f);
            material.SetFloat("_Metallic", 0.097f);
            material.SetFloat("_Glossiness", 0.763f);
            material.SetFloat("_Cutoff", 0.13f);
            AssetDatabase.CreateAsset(material, "Assets/Resources/Achievements/" + t.name + ".mat");
        }
    }

Is this a bug, and if it is, is there a workaround other than wiggling the alpha cutoff with mouse?

I think it is a bug, I have the same situation. but when you change any value in inspector, the cutoff effect will be right.

my solution is to create material in file, then change it type to cutout in inspector.
in script: copy and load this material from file, then modify the other parameters.

Change the material.color alpha value. This worked last time I worked with alphas.