Trying to connect to asset store inside Unity3D[SOLVED]

Hello, I’m trying to connect to the asset store inside Unity(On windows the keyword is Ctrl+9), I did a research about this problem, and none of them fit on where I’am.

alt text

The error shown in the image is not explainable, it does not tell what got wrong while trying to connect to the Asset Store, and yes, I can access the asset store inside explorer, the firewall was disabled/enabled, I tried a lot of things, but none of them worked.

Thanks in advance!

If by “trying to connect” you mean that the Asset Store shows up gray, then see if unticking “Use Direct3D 11*” checkbox under “Edit” → “Project Settings” → “Player” fixes your issue. Note this is for Windows users as OSX probably doesn’t have that checkbox or if it does, it shouldn’t be of relevance.

Original answer from: Asset Store Is Just A Grey Screen - Unity Answers


Don’t just open the asset store in Internet Explorer, log in with it. This might also send the same session to Unity Editor. For some this has also fixed this issue.