.tsx files opening in visual studios instead of tiled

Hello, as I said my .tsx files have been opening in visual studios instead of tiled. They have the error
SuperTiled2Unity version: 1.10.5, Unity version: 2019.4.19f1
Missing texture asset: …/…/…/…/…/Sprites/TheHouse.png
and when ever I open them to try to fix this it opens visual studios instead of tiled. I have no idea how to fix this.

solved! turns out I just had to change the default app in my settings