turn off bilinear filtering at fullscreen

When I export in Unity and set to fullscreen, mac osx generates the upscaled view with bilinear filtering.

Is there a way to turn this off?

There’s no way to change the filtering; you’d need to use Unity Pro and rendertextures to render the 424x240 resolution to a texture, which is scaled to the actual screen resolution. So you would be running at the full resolution, rather than upscaling a window.

You’ll have to select your textures, and in their import settings select nearest neighbor in the filtering drop menu.

Just select the sprite that has that issue and in the inspector, change it from bilinear to point:

39275-untitled.png