Turn on vsync in the editor Scene window.

Is there a way to enable vsync in the editor for the Scene window ?

When I am moving about in the scene my graphics card is whining.

Thanks.

Turn it on in the quality settings. Whatever quality setting you have currently selected is the setting for the editor.

--Eric

1 Like

I have but the card still whines..

VSync wouldn't have anything to do with your card whining. And by whining, I assume you mean the fan is ramping up in speed. Nothing you change in Unity is going to affect that. You'll have to look into whether your graphics card's driver has a control for the fan speed or find another way to set the speed to a lower setting or underclock the GPU.

Actually, vsync often can have a lot to do with overheating since to burns through frames as fast as it possibly can, consuming more power.

4 Likes

Vsync does have an effect on cards whining and it's not the fan. For example I had a game a while back that was trying to run at silly FPS and the card whined. It's an R9 280X. Forcing the vsync on with D3DOverider worked and the whining stopped. This is the same whining that Unity is causing, albeit it unintentionally and a little less. Technically this is called 'coil whine'.

The idea with controlling vsync, as I am trying to do, is to stop more powerful cards from maxing out and running at full speed when unnecessary, which can cause coil whine.

D3DOverider seems to have no effect on Unity though sadly. So I was asking if there was anything in Unity that I could set up, but it appears not. It's just a little annoying but I can live with it.

3 Likes

Yes hippocoder - this is my concern, but as it's not all the time I think I can live with it unless I can find a solution.

I see, makes sense.

Have you verified the changes you made to quality settings did enable VSync? Just open the Stats box with the game running and if it shows over 60fps, you should check your settings again and make sure they apply to quality setting currently assigned to the editor.

Yes in the game window it runs at the expected 60fps give or take 5 frames. So something is working. It's just the Scene window when it occurs.

There are no settings specifically for the scene view, so if changing the editor quality settings didn't stop it, then there isn't a setting I know of in Unity that will help, unfortunately. :(

1 Like

OK well thanks for suggesting a few things and for your time :)

I'll dig around the net to see what I can find.

I checked my graphic card driver ( AMD Catalyst) and made a profile for Unity that forced vsync on but still the same. I did read that sometimes programs that run in windows don't respect vsync but in full screen they do. It's funny how the Game window does respect it though and the Scene window doesn't.

Oh well, if I find anything I will drop it in here for future reference.

Cheers :)

Back again, just to prove this is a real problem I ran fraps and got the FPS while moving around in the editor.

Here's my Scene window. It actually went well over 300 FPS

So clearly the Scene window is not being controlled by the Quality settings.

Getting worried about my expensive graphics card now :eyes:

If the graphics card is hurt by rendering frames, there's something wrong with it; 300fps isn't even really that high.

--Eric

I think you are missing the point of vsync and how not controlling it can damage a graphics card...

1 Like

No, I don't think so. You should be able to use the full capabilities of your card without damaging it in normal operation, and it's not required to use vsync as a normal operation. I've certainly never owned a card which was ever damaged by running "too fast", nor have I ever heard of such a thing. Cards will throttle down if they start to exceed thermal parameters in order to avoid overheating.

--Eric

1 Like

Hmm yes I think I agree with you there actually, I can't say I have had a problem in that department with any card. My card has adequate cooling - it's a good design. It's just this whining that is new to me, so I was concerned as well as irritated...

It might be a fault in the card. I once had a card that had a few bits of bad VRAM, which would show up (depending on where stuff was located in VRAM) as wrong-colored pixels in textures, or vertices in models that were way way off. It was kinda annoying....

--Eric

I was reading about coil whine some more and it's just one of those things that can happen with electrical components sometimes, well so I have read. This has only happened on one game and Unity so far, since last year sometime.

I asked MSI who made my card about it and they said to enable vsync and that solved it. It's reassuring that my card is probably safe in the end. I'd just like to stop it running at silly FPS when it's unnecessary and in doing so stop the whining.

I know you mentioned using D3DOverider but have you tried forcing VSync in the Catalyst control panel directly? I haven't use an AMD card since they were ATI, but you can do this pretty easily on NVidia cards.

Yep I tried that in the AMD Catalyst control centre.

I have it set to use vsync globally and I also tried making a configuration just for Unity, none of this worked.

I think it's the problem that perhaps (not entirely sure atm) vsync only works on full screen. What with the Scene window being in a...well...window... seems to make it ignore the settings.

I don't think this can be fixed, I'll just have to put up with it.