Ugly shading issue

Hi.

I’m having some issues with Unity’s lighting. I have a single directional light in the scene. I’m trying to create a walkway from tiles I created quickly in blender. As you can see, the lighting looks pretty awful as there are noticeable lines between the tiles. The normal’s should be fine, so I’m left wondering if there is some way to easily fix the ugly shadows.

Alt text

Thank you,

D4rt

Nobody can answer this confidently because your image link is broken, but I’m going to go out on a limb and guess it’s because your normals are averaged instead of split at the edges. If that’s it, you’ll find a lot of images/instructions on how to deal with that. Kicking the smoothing angle up all the way on the importer is a good place to start, and possibly finish.

Try to to set the “normals” option to “calculate” at the import tab when you select the imported blender model