UI Canvas buttons not working

I am facing an issue with my UI buttons.
I have two canvases. On both I have buttons, 1 canvas has buttons to enter value in an input field which is placed in that canvas.
Otyher canvas has buttons which on being clicked should load another scene. This worked for me the first time I build . Then, it stopped working when I tried to run and see if the button highlighted color chasnges and if they are clickable. nothing happened. Then I changed the canvas order in layer for both canvases as 0 and 1. It started working again, and now again the buttons are not working. I had this problem with another scene, so I started creating the scene from scratch as a new scene, and having the same weird issue again. please help as Im new to this.

this is the keyboard canvas
alt text

Without more information, my guess is you have panels at the background of those canvases that might be invisible but are still there and still getting raycasted. So, one on top of the other means that the lower one in the hierarchy isn’t getting clicks.

please let me know what more information do I need to provide.
Each of the canvas has a panel and within the panel I have the buttons