UI (Canvas) element disappears when loading additive scene

Hi everyone,

I´ve been struggling with this issue for a while but haven´t been able to find an answer anywhere.

Basically, I have two scenes: Intermission and Game scenes. The first one has no camera and is persistent. It is responsible for creating a overlay canvas and loading the Game scene in additive mode. The Game scene runs the proper gameplay (duh) and has a UI element in place. They work fine when loaded separated. However, everytime the Intermission scene loads the Game one, the U element of the latter does not work. It is there in the work tree, but it´s not shown in the game, neither in the scene view. I believe it´s a Unity bug, but I haven´t been able to find a workaround for it.

I´ve tried using different cameras, removing the canvas from one of them and instantiating the UI game object on the fly, but nothing has worked. The issue seems to happen everytime the additive scene gets loaded. And yes, it´s very important to keep the first scene (Intermission) loaded (I cannot just load another scene and remove it ).

Are there any suggestions?

Thanks in advance,


@perolleiro hi
Maybe this is very later response, but here is answer:
Go to that scene you want to load additive, select the Camera and set “Clear flags” to “Don’t Clear”.