UI components all disappear on Play mode, then stay invisible

Hi !
I have a complex UI object in World Space. Everything worked until I applied the Prefab from the scene, not on Opening the prefab.

Now when I launch Unity the UI shows, but as soon as I run the scene, it disappears, then stays invisible even on exiting play mode…
The GameObjects are present and active but images and text with UI default material don’t show anymore.

The only thing left is the TextMesh Pro texts. One clue might be that I use both UI.Text and TextMesh Pro texts…
This is not a layer problem, as all my layers are marked as visible.

Do you have an idea on what’s happening? The prefab might be corrupted or what? The new prefab system has gotten me trouble more than once…

Thank you for your help !

Alright now I upgraded to 2018.4 which is LTS, and now it works.
To anyone whom would have the same problem…

[EDIT] WOW ! That was pretty messed up ! So here it goes :
I have a method in another functionality that changes an image’s alpha opacity, totally unrelated.
But in the script, i changed the image.material.color.a, not the image.color.a,
Which actually was modifying the Unity UI default material common to all my UI components ! And it is NOT editable in the Editor ! Changes are also permanent after exiting Play mode (serialization stuff I guess) !

SO : changing image.color.a did the trick.
So relieved…

Try this.
Canvas Inspector> Canvas Scaler> UI Scale Mode> (Scale With Screen)