UI.Image not showing when using non default shader/material

Hey Guys,

I have a problem that you might be able to assist with.

When I assign a custom (or any shader) to a UI.Image it renders perfectly in the editor - but when I compile it and run it it shows a null sprite. Ive tried this on another machine as well in a fresh scene and I get the same results. The mesh seems to be there, because the mouse over events are still called, but the graphic does not show.

Ive tried to put the material in the resources folder but I get the same result. I assume its an engine issue as its fixed in the latter versions of Unity - but I have no desire to switch.

I am using 5.2.4 - I have tried with earlier versions with no success. When I upgraded to 5.3.x - the issue was resolved, however I am getting bad overall performance with 5.3 and I would prefer to stay with 5.2 - any ideas on how to fix this?

If I change to window mode on the build- it works fine.

I am using Pro on a mac.

I upgraded to the newest 5.3.4f1 and it is working properly.

This is happening to me in 5.6.3p1 when using no source image and no material (basically just a default colored square)