UI object above particles issue - Scene View different from the Game View

In my Canvas I have Particles and an Image. I would like to play those particles in the background and see that image in the foreground - above the particles. I set Canvas Render Mode to Camera and attached my main orthographic camera. Sorting Layer of the Canvas is the Default and Order in Layer is 0. Particles have in the Renderer section also same sorting options… I added Canvas component to my Image, set Override Sorting option to true and created new Sorting Layer above the Default one and set this Layer to the Image. In the Scene View I can see right result - Particles below the Image. However, in the Game View, order is incorrect - image below particles. I am building on Android so I tried real device and results are same as in the Game View. I think I set everything correctly. Also tried to move that image closer to the Camera. So I created new project and tried the same thing - and it works as expected. I have really huge project. But it seems there is some bug or don’t know what and it needs to be refreshed. But I don’t know how to correctly handle that. Any ideas would be appreciated.

Hi Kristián, today is your lucky day. I think I know what is the problem. I had the same problem and I noticed that I had 2 Cameras in my scene. The first camera has depth parameter 0 and the second 100. The Particle system is not a part of Canvas, so the second camera also took a part in final image in your scene. You sad that you have really huge project, so I think you have more than 1 camera in your scene. If it is so, try to disable other cameras and you will see the result.