UI with layer always displaying

I made 2 camera’s. One camera ignores the layer ‘notVisible’ and the other one not. Then I created a rawimage with the layer selected as ‘notVisible’. But still both camera’s are displaying the rawimage in game. What do I need to do?

Hi @martn00 , here you need to tweak your Canvas a little bit.

  1. First of all, set both camera’s culling mask to ‘Everything’.
  2. Now, select Canvas from the hierarchy and locate its ‘Canvas’ component in the Inspector. (See Img)97735-canvas-tweak.jpg
  3. Then change its 'Render Mode from “Screen Space - Overlay” to “Screen Space - Camera” (See Img)
  4. Finally, Drag your desired camera through which you want to display the Raw Image.
  5. Now run the scene and try to disable the camera other than that you have dragged onto the Component. (See Img! Try to disable Camera2 from the hierarchy while running the scene or as it is).

I hope it will solve your issue upto some extents