Unable to Activate Unity License

I’ve just downloaded Unity 5.4.1 and am unable to use it because of an error with license activation. I am running Windows 10.

  1. A progress bar checks my license.
  2. License management comes up and I select personal.
  3. I give it a few details and it says that it’s updating license.
  4. The software comes back saying “Something went wrong” and offers to let me activate manually.
  5. I go through the manual activation which returns this screen:


I’ve tried running as an administrator, disabling my vpn, deleting the unity folder in /ProgramData, and have repeated this with and installation of 5.4.0 and 5.3.6.

I have an email thanking me for activating.

I don’t understand the need for these license hurdles on free software. Does anyone have any experience with fixing this?

Thanks guys.

Try to run as administrator. Work for me

@AldrinOlay, as my original post stated: “I’ve tried running as an administrator”.

I figured out the problem though.

I guess, I’d started an account with Unity several years ago and this was preventing my licensing on this machine with a new account. I don’t remember doing it and it was very confusing.

Unity needs to add more specific details to users and not return generic errors to make this easier to troubleshoot.