Unable to add Completion Criteria to any Tutorial Pages

Hey everyone!
First, let me say I absolutely love the In-Editor Tutorials feature. It's a great idea and the execution is really well done (apart from a bug here or there!).
Unfortunately, I'm running into issues while trying to add Completion Criteria to any of my tutorials. This is occurring in a brand new project with only the necessary packages added. I've already submitted the bug report (Case 1336108), but I wanted to see if anyone else is running into this same issue. Basically, I started a new project on Unity 2019.4.12f1 using the basic 3d template, then followed the steps here: https://docs.unity3d.com/Packages/com.unity.learn.iet-framework@2.0/manual/index.html
Then, when trying to add Completion Criteria to any tutorial page, I receive two errors in the console and I'm unable to edit the settings for the criterion to make it actually functional.
7141397--854171--upload_2021-5-14_10-25-10.png
7141397--854174--upload_2021-5-14_10-25-41.png
Has anyone else run into this issue? I'd really like to utilize this amazing feature. Thank you for your time!
Bwavo

Hi @Bwavo ! Unfortunately, IET 2.0.0-pre.4 has this issue with Unity 2019. We fixed it in 2.0.0-pre.5, which hopefully will be released this week.
In the meantime, unless you have specific reasons for sticking with 2019.4, I'd recommend upgrading to unity 2020.3 LTS and use IET there

Thank you @PaoloAbela ! I'm happy to hear there is a fix on the way. I'll have to look into upgrading to 2020 LTS, I'd always heard upgrading your Unity version mid-project was not recommended.

[quote=“Bwavo”, post:3, topic: 840888]
I’ll have to look into upgrading to 2020 LTS, I’d always heard upgrading your Unity version mid-project was not recommended.
[/quote]

I totally feel you! But I have to say that I recently upgraded a ~1 year URP multiplayer project from 2019.4 LTS to 2020.3 LTS, the smoothest upgrade of my life as a Unity Game Developer. Literally nothing broke, in my case!

Hi. We've just released pre.5 versions of the packages and those versions will contain a fix for this issue.

Hello and good day.

I see that will be suppose to be fixed, but I get a different issue, if I try to add a criteria got this... without any error on console.

8924039--1222736--upload_2023-4-3_7-47-2.png

Instead of this...

8924039--1222739--upload_2023-4-3_7-47-23.png

I tried on 2021 and 2022 (not LTS), without getting a working result, I notice that the documentation it's a quite bit downgrade (the images does not match) and the create Callback Handler button does not exist..

In documentation:
8924039--1222748--upload_2023-4-3_7-51-49.png

In Asset Inspector:
8924039--1222751--upload_2023-4-3_7-54-22.png

There will be some miss take from my part or definately it's another bug, any help will be appreciated, thanks for you attention, have a nice day.