Unable to alter color properties in shader graphs

Hello,
In Unity 2019.4.13f1, I am attempting to create a shader with two different color properties from the blackboard. I am unable to alter the default color value of the property. Clicking or right clicking on the black bar next to “Default” does nothing. The same goes for color nodes created within the graph itself. Their value cannot be changed either.

The external property can be edited in the material instance in the usual Unity editor/inspector view.

170127-color-property-issue.png

Is there a system/project setting that I have incorrect or is there another cause for this?

Thanks in advance!

It says this is a “known issue” in the patch notes for the .13 through .15 (latest at time of writing) releases for 2019.4. See issue tracker here

That page lists another workaround: try holding CTRL while clicking the color box. This worked for me, btw. If that doesn’t work, try using Alt or Shift.

im having the same problem. please help

Hey! I just updated my unity to 2020.1.13f1 and I got my shader graph to open color window. Hope it helps anyone here. :slight_smile:

Solved it on Unity 2019.4 by holding shift while clicking on the color property.