Unable to animate bones for a Humanoid

I am trying to animate a humanoid character. I am successfully able to move or rotate the bones as i please when not recording. However as soon as I try to record an animation and click on the recording button, My character automatically slouches into a jump position and I am unable to move or rotate any bone (I can drag them but they just revert back to their original position).

Link to a gif showing whats happening

This just happened to me with 2D bones. I later found out that the game object I was trying to animate had inside two sets of the same bones, so whenever I tried to change the position of a bone while recording, it went back to its original position (because it was the same position that its “twin” bone still had, so there was a conflict since they had the same identifiers). Removing the first set of bones solved the problem. It actually was an older version of the skeleton I did for the game object, and as I modified the skeleton and added new bones to it, that’s how another version of it appeared. The bones that existed only in one of the versions were the only ones I could move before solving the problem.