Unable to find java in the system path

Every time I press play in the editor, I get a popup saying

150924-android-resolver.png

This is an android project collaborating with two other people I just met and it’s been awhile since I touched unity. Following the documentation I should look for external tools setup in preferences and they look like they should according to my new friends

Unity Hub modules install is set up with full Android Build Support (Android SDK & NDK Tools and OpenJDK).

So it appears that one strange way to fix it is to uncheck the “x installed with Unity (recommended)” and then click the browse button that will appear to automatically find the JDK, SDK, NDK, Gradle etc. I still get warnings about not using the recommended version for whatever reason, but at least I can now press play without that popup in my face again.

150929-solved.png

I found the easiest way to solve this. Open your Unity Hub, then go to Installs. Select the unity version you are using and then click on “add modules”. The Android Build Support has > button, and if you click it, it will show you both Android SDK&NDK Tools and OpenJDK unchecked for some reason. Just check them and click Done. That should fix it! :slight_smile:

I just ran into this issue after updating to 2023.30b3. I unchecked the boxes, saved, and exited. Then restarted the app rechecked the boxes and it worked!

Problem fixed here : Unity 2021 Android Support: Setup, JDK & SDK & NDK & Gradle - YouTube