Unable to install Unity Asset Server 2.0

I tried installing the asset server on windows 2003 and XP pro, both installations give me the "failed to call initialize database command".

I used the admin login during installation.

Anyone got it to work on either of the machines?

P.S: I know it works on mac os

Two problems have surfaced in the 2.0.0 Windows installer, one is that for some people the unity asset server user is not created correctly, another is that the initialization of the database fails to execute. For others everything works, including all the machines tested at the Unity office, it seems unrelated to OS version. A fix is in the works but it depends on users with this problem testing out the next release to see if the fix works for them. If you have this problem you could send in a bug report and possibly get an early release of the fixed installer and thus make sure it works for you.

Probably is a problem with your ENV vars on Windows.. Do you know which Command is being called? have you tried to see which ENV vars you have declared ? :) This is not an answer but it can help you out finding the problems!

I had the same problem Pranay. Today I tried to install the asset server on my WinXP PC at work and I got the same problem during the install process - "Failed to call initialize database command '1326'" and the installation failed (the "Unity Asset Server" service was in my service control panel, but I couldn't start it).

When I got home this evening, I tried agian to install the Unity Asset Server on my Windows 7 PC and it worked like a charm! No errors and no problems - the service is running and I was able to create a new project and populate the assets with my local project files!

The only difference that I think that will have a major impact during installation was the fact that my work PC is a memeber of a domain. The Unity Asset Server installer will try to create a local user account on the installation PC that will be used to administer the SQL database (unitysrv is the user name for this account) and I have a suspision that a user account can't be created in this way on a computer that is a memeber of a domain - or your user account that you used to install the service doesn't have sufficient permissions to add a user to the local computer.

My Windows PC at home is not a member of a domain and the user I installed the asset server has administrative account rights so the creation of the unitysrv user account worked without any problems.

Does this sound like it could be the problem you are experiencing? Are you trying to install the Unity Asset Server on a computer that is in a domain and your not logged on with a domain administrator user account when installing the server?

Problem still exist, and no fixes from UT for several months! I have Windows 2003 Server Pc as a member of domain, and i get same 1326 error while trying to install AS2. Using advice above, i've removed computer from domain, and logged in as a local administrator. Then, for the first time application was installed without 1326 error. But, it still doesn't work. This time "admin" role was not created and i can't reset admin password or log in with initial one. Server can't be started, strange error in log:

psql: could not connect to server: Connection refused (0x0000274D/10061) Is the server running on host "???" and accepting

I had troubles installing the Asset Server on Windows 7. My problem was not the same but I thought maybe others might have this problem. Basically the psql.exe commands were failing to run and create the user/db/etc but the errors were not reported by the installer.

The problem seems like it was a path/env problem stemming from the fact that I had a space in the install path “Program Files”. When I tried installing in c:\UnityAS then everything installed and worked ok.

Hope this helps a few people with install problems.