unable to list target platform

similar to this question above with the exception that i do not have any kind of folder like that

Error building Player: CommandInvokationFailure: Unable to list target platforms. Please make sure the android sdk path is correct. See the Console for more details.
C:/Program Files (x86)/Java/jdk1.8.0_112\bin\java.exe -Xmx1024M -Dcom.android.sdkmanager.toolsdir=“C:/Users/sw-user2/AppData/Local/Android/sdk ools” -Dfile.encoding=UTF8 -jar “C:\Program Files\Unity\Editor\Data\PlaybackEngines\AndroidPlayer/Tools\sdktools.jar” -

this was working a day before i entered android studio and i updated some stuff ( i think it was sdk as well) and then this happened i cant run my unity project

Found a solution here: not finding android sdk (Unity) - Stack Overflow

I have same problem.

I fixed by android sdk tool version

The steps.

Rename android sdk tool folder : [Your
Android SDK root]/tools → toolsXXXX
Download SDK Tools:
Extract that to Android SDK root Build
your project

It worked for me :slight_smile:

If you are a MacOS user, you can download here: https://dl.google.com/android/repository/tools_r25.2.5-macosx.zip

Thanks @molul,

Yesterday I updated all my tools to Unity 5.6.0f3, Android Studio 2.3.1, and JDK 1.8.0_131. Then got the “Unable to …” error.

I followed your fix using tools_r25.2.5-windows.zip on Windows 10, and then it worked.

Many thanks for sharing this. It saved me a lot of work.

Same problem here.

I updated Unity 5.5 and Android SDK and all goes crazy.

This solution (downgrade SDK) work like a charm for me and save my day.

Never forget if something works , no updates , lol.

Unity 5.5.2f

How can I Solve this in Mac?

Thanks to everybody that has contributed to this solution. I work on MacOS. I downloaded: tools_r25.2.5-macosx.zip from the link provided above AND NOT: sdk-tools-darwin-3859397.zip that is found at https://developer.android.com/studio/index.html today (Aug 13, 2017).

Unity should have been providing this solution at the Getting started with Android development page (https://docs.unity3d.com/Manual/android-GettingStarted.html)

Easier solution: set the environment variable USE_SDK_WRAPPER=1, or hack tools/android.bat to add the line “set USE_SDK_WRAPPER=1”. This prevents android.bat from popping up a “y/n” prompt, which is what’s confusing Unity.

@Bunny83, can you unlock Unable to list target platforms. Please make sure the android sdk path is correct. See the Console for more details. - Questions & Answers - Unity Discussions so I can add this info?

It helps me too:)

просто удалите tools и поставьте этот на его место =)
или этот

To quote my answer from Stack Overflow:

The error happens due to this Unity
bug (related to the latest Android SDK
tools version). You can see in the
error message that the “manifmerger”
tool returns an error code (64):

stderr[ Error:Invalid command
manifmerger ] stdout[

] exit code: 64

The bug is fixed in the latest Unity
(beta) version. There is a workaround,
as described on that page:

Workaround for the customers.

just open
Download Android Studio & App Tools - Android Developers
scroll down to the bottom of that page
go to downloads scroll down to the
bottom of that page find Windows
tools_r25.2.3-windows.zip” download
and unzip it or, on mac: find MacOSX
tools_r25.2.3-macosx.zip” download
and unzip it. In the SDK path replace
the tools folder. This is a quote from
the issuetracker page. I’ve added
direct links to the downloads, since
they seem to be missing from the
Android website.

I still have the same problem even though I did what you wrote … What else can you do?