Unable to open scripts

Whenever I try to open a script for editing, I get an “Unable to open Assets/Scripts/PlayerController.cs: Check external application preferences” error.

  • This is a new script. I have not moved it in my file browser.
  • Under “Preferences > External Tools” I have External Script Editor set to “MonoDevelop (build-in)”.
  • I have just reinstalled Unity, and made sure the “MonoDevelop” option was selected.

I’m running Unity 4.5.5f1 on Windows 7.

Anybody know what’s going wrong?

EDIT: I’ve tried manually finding the .exe in the External Script Editor preference (using “Browse…”). Now I have a new error: A terminal pops up for a split second with the message “Cannot open assembly ‘’: File does not contain a valid CIL image.”

Shut down Unity. Then find a .cs file in Explorer. Double-click it, and I think Windows won’t know what to use to open it. Tell Windows to open the script file with MonoDevelop.

I am having a similar problem. In my case there is a .dll file which is being mentioned in error. Exact text is as under

Unable to open Packages/com.ptc.vuforia.engine/Vuforia/Plugins/Managed/iOS/Vuforia.UnityExtensions.dll: Check external application preferences.

Now I have manually checked, .dll file exists. I have no idea what is going on. Previously it was working fine. Interestingly this error only occurs when I try to edit “Default Image Behaviour (Script)”… all other scripts are being loaded by Visual Studio 2017 perfectly. Things went bad when I installed iOS build support along with already Android built support.